Delayed Status Callback Delivery and Inbound Traffic Issues in the WhatsApp Channel

Incident Report for Vonage API Status

Resolved

Vonage services are fully restored following today's interruption in delayed status callback delivery and inbound traffic issues in the WhatsApp channel from 2026-05-19 04:13:00 UTC until 2026-05-19 06:45:00 UTC.

Thank you for your patience and understanding as we worked to restore services as quickly as possible.

If you have any questions, please contact api.support.vonage.com
Posted May 19, 2026 - 07:15 UTC

Monitoring

Vonage services continue to show signs of recovery following today's interruption in delayed status callback delivery and inbound traffic issues in the WhatsApp channel.

We'll continue to provide further updates here within 60 minutes and once full service is restored.

Thank you for your patience and understanding as we work to restore services as quickly as possible.

If you have any questions, please contact api.support.vonage.com
Posted May 19, 2026 - 06:22 UTC

Update

We have identified an issue with a third-party supplier that is impacting the delivery of status callbacks for the WhatsApp channel in both the Messages API and Verify API V2.

We also observed that the incident is impacting inbound WhatsApp traffic for the Messages API, resulting in inbound message delivery failures.

We’ll continue to provide further updates here within 60 minutes.

Thank you for your patience and understanding.

If you have any questions, please contact api.support.vonage.com
Posted May 19, 2026 - 05:58 UTC

Identified

Our engineering team has identified the issue that is impacting the delivery of status callbacks for the WhatsApp channel in both the Messages API and Verify API V2.

We will continue to provide further updates within 60 minutes.

Thank you for your patience and understanding.

If you have any questions, please contact api.support.vonage.com
Posted May 19, 2026 - 05:20 UTC

Update

Our engineering team is actively working to resolve the issue affecting the delivery of status callbacks for the WhatsApp channel in both the Messages API and Verify API V2, which is causing delayed callback notifications.

We'll continue to provide further updates here within 60 minutes.

Thank you for your patience and understanding.

If you have any questions, please contact api.support.vonage.com
Posted May 19, 2026 - 05:04 UTC

Investigating

We are aware of an issue that may be affecting callback delivery for the WhatsApp channel within the Messages API, resulting in delayed callback delivery.

Our engineers are working to quickly resolve the issue. We’ll provide further updates within 90 minutes.

Thank you for your patience and understanding.

If you have any questions, please contact api.support.vonage.com
Posted May 19, 2026 - 04:41 UTC
This incident affected: SMS & Messages (Callbacks, Messages API) and Auth & Identity (Verify V2).