We have monitored and observed no further issues and will resolve this incident. We will share more details in the RFO within the next few days.
Posted Aug 06, 2025 - 10:10 UTC
Update
The services are now stable, and we continue to monitor the platform.
Posted Aug 06, 2025 - 02:10 UTC
Monitoring
We have implemented a fix for this issue and our metrics currently indicate call success rates have returned to normal levels.
Customers may have experienced call failures and dead air on inbound and outbound calls in any region, with the majority of impact affecting North America.
The list of impacted services has been confirmed as follows: Voice API - Inbound and Outbound Voice Calls
We will continue to monitor services during the next few hours and post updates should anything change.
Posted Aug 05, 2025 - 22:56 UTC
Update
Our teams continue to work on mitigation efforts to reduce the impact.
We have identified the cause of the issue to be related to extremely high levels of inbound traffic from certain providers, which is impacting our platform. We are pursuing multiple avenues with both internal and external vendors to mitigate the ongoing impact to our customers.
We will continue to provide regular status updates on this page.
Posted Aug 05, 2025 - 20:52 UTC
Update
Our teams continue to work on mitigation efforts to reduce the impact to customer calls.
We aim to provide another update in 1 hour.
Posted Aug 05, 2025 - 19:06 UTC
Identified
Our engineering team as identified the cause of the issue and are continuing to work on mitigation efforts to reduce the impact to customer calls.
We aim to provide another update in 1 hour.
Posted Aug 05, 2025 - 17:58 UTC
Update
We are continuing to investigate this issue and we appreciate your patience.
The list of impacted services has been confirmed as follows: Voice API - Inbound and Outbound Voice Calls
We aim to provide another update in 1 hour.
Posted Aug 05, 2025 - 16:53 UTC
Investigating
Our monitoring has alerted us to a potential downstream service issue with our suppliers that may be impacting Voice
Although It is not yet certain whether there is any customer impact, we are alerting customers immediately while our teams investigate.
We aim to provide an update on our investigation within 1 hour.