Planned Maintenance on EU West Voice Servers

Scheduled for Jun 16, 05:30 - 08:30 UTC

Update

This planned maintenance on the EU RTC Servers handling Voice traffic in the EUW1 (EU-3 / eu-west) region has been rescheduled to June 16th, 05:30 - 08:30 UTC.
Posted Jun 05, 2026 - 16:13 UTC

Scheduled

We will be undergoing scheduled maintenance on the EU RTC Servers handling Voice traffic in the EUW1 (EU-3 / eu-west) region. During this time, API requests and calls may be routed to the EUC1 (EU-4 / eu-central) region. Customers may experience a minor impact on ongoing calls during this period.
Posted May 27, 2026 - 17:48 UTC
This scheduled maintenance affects: Voice (Programmable SIP & SIP Interconnect, Voice API, SIP Trunking, Voice WebRTC) and Auth & Identity (Verify, Verify V2).