Reports API Usage Data Visibility Issues

Incident Report for Vonage API Status

Resolved

The implemented fix has stabilized the system, and we have successfully processed the backlog of data. All systems are operating normally, and data visibility has been fully restored.

Thank you for your patience throughout this process.

If you have any further questions, please contact support@api.vonage.com
Posted Mar 24, 2026 - 00:03 UTC

Update

The fix for the Reports API visibility issue has been implemented. We are now in the recovery phase and are working through a backlog of data.

Please note that data may remain delayed until the system is fully caught up.

We are continuing to monitor the situation and will provide a follow-up update within 2 hours.
Thank you for your continued patience.

If you have any questions, please contact support@api.vonage.com
Posted Mar 23, 2026 - 21:09 UTC

Update

We have identified the issue that was impacting your Reports API usage data visibility and have applied a fix.
The system is currently processing a backlog, so you may continue to experience delays until the backlog clears.

We are monitoring the recovery and will continue to provide further updates within 2 hours and once full service is restored.

Thank you for your patience and understanding.

If you have any questions, please contact support@api.vonage.com
Posted Mar 23, 2026 - 19:56 UTC

Monitoring

We have identified the issue that may be impacting your Reports API usage data visibility and have applied an initial fix.

We will continue to provide further updates within 2 hours, and once full service is restored.

Thank you for your patience and understanding.

If you have any questions, please contact support@api.vonage.com
Posted Mar 23, 2026 - 17:42 UTC

Investigating

A subset of customers are currently experiencing issues with viewing usage data while using the Reports API. Our engineering team is actively investigating and working to resolve the issue.

The following services have been impacted since 2026-03-23 21:00 UTC.

We will continue to share updates here within the next 2 hours or as soon as more information becomes available.
Posted Mar 23, 2026 - 15:53 UTC
This incident affected: Vonage Platform Management (Reports API).