USA SMS - Delivery Degradation affecting traffic towards T-Mobile Network

Incident Report for Vonage API Status

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 13:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2026 - 12:05 UTC

Update

We are continuing to investigate this issue.
Posted Jul 09, 2026 - 10:20 UTC

Investigating

We are currently experiencing message delivery issues impacting SMS traffic towards T-Mobile USA. As a result, you may experience delays, failures or missing delivery receipts for outbound messages.

Our supplier is aware of this issue and investigating the root cause as a matter of urgency. We will post an update as soon as more information becomes available.

If you have any questions, please contact api.support.vonage.com
Posted Jul 09, 2026 - 10:13 UTC
This incident affected: Global Connectivity (SMS North America).