Vonage Customer Dashboard login issue

Incident Report for Vonage API Status

Resolved

Vonage services have been fully restored following today’s service outage, which began 2026-04-29 16:53:16.308139 UTC. Full resolution has been confirmed effective 2026-04-29T18:51:00.000+0000 UTC. Thank you for your patience and understanding as we worked to restore services as quickly as possible.

If you have any questions, please contact api.support.vonage.com
Posted Apr 29, 2026 - 20:48 UTC

Monitoring

Vonage services continue to show signs of recovery following today's interruption, impacting the dashboard login. Thank you for your patience and understanding. If you have any questions, please contact api.support.vonage.com
Posted Apr 29, 2026 - 19:06 UTC

Identified

We have identified the issue that was impacting the dashboard login issues and seeing signs of recovery. We'll continue to provide further updates and once full service is restored. Thank you for your patience and understanding. If you have any questions, please contact api.support.vonage.com
Posted Apr 29, 2026 - 18:34 UTC

Investigating

We are aware of issues that may be impacting signing in to the Vonage dashboard.

We are working to resolve the issue as soon as possible. Thank you for your patience and understanding. If you have any questions, please contact api.support.vonage.com
Posted Apr 29, 2026 - 18:10 UTC
This incident affected: Vonage Dashboard (Customer Portal).